Royal Enfield Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,
Just received my Classic 350 Halcyon gray over weekend and found the alignment problem of rear wheel vs. center of mudguard. Dealer in TH they said all of 350 has this as common defects.
Anyone get this issue ?, not sure how can rectify?
Tire Wheel Automotive tail & brake light Vehicle Automotive tire
 

·
Registered
Joined
·
4 Posts
Is the wheel properly aligned in the swing arm? Does the chain run in the middle of the rear sprocket or off to one side? If those are ok, I would not worry about it too much. You could probably give the fender a little twist to correct. Or stand father to the right and the fender will appear centered.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Is the wheel properly aligned in the swing arm? Does the chain run in the middle of the rear sprocket or off to one side? If those are ok, I would not worry about it too much. You could probably give the fender a little twist to correct. Or stand father to the right and the fender will appear centered.
Yes, the wheel is properly aligned ith swing arm and chain runs without any problems, I think the fender and mounting frame wasn't aligned (more on right side), i try to loose all bolts/nuts and pull to the left this just a little bit help. Many RE3590 in Thailand is like this and i think it was abt build quality from the factory. BTW the ride quality is deem good 👍
 
1 - 4 of 4 Posts
Top